Blogger templates

I Support the Bring Them Back Campaign

1 Ιουλ 2017

Αναβαθμίστε το Linux λειτουργικό σας άμεσα!

Η ευπάθεια με το αναγνωριστικό CVE-2017-9445 μπορεί να επιτρέψει την εκτέλεση κακόβουλου κώδικα από απομακρυσμένους εισβολείς στα επηρεαζόμενα συστήματα. Το ελάττωμα έγκειται στο SystemD, το σύστημα εκκίνησης και διαχείρισης υπηρεσιών που υπάρχει προεγκατεστημένο σε αρκετές δημοφιλείς διανομές  των Linux.


O προγραμματιστής της Canonical, Chris Coulson, o oποίος ανακάλυψε το κενό ασφάλειας αναφέρει:

“Ένας απομακρυσμένος επιτιθέμενος μπορεί να πυροδοτήσει την ευπάθεια buffer overflow για εκτέλεση κακόβουλου κώδικα, μόνο με ένα κακόβουλο DNS response”.

Ο εμπειρογνώμονας εντόπισε την ευπάθεια στο function ‘dns_packet_new’ του ‘systemd-resolved’, που χειρίζεται τα DNS responses & παρέχει ανάλυση του ονόματος δικτύου σε τοπικές εφαρμογές.

Ένα ειδικά διαμορφωμένο DNS response μπορεί να προκαλέσει την κατάρρευση του ‘systemd-resolved’. Αυτό μπορεί να γίνει κάθε φορά που το σύστημα αναζητεί ένα όνομα κεντρικού υπολογιστή (hostname lookup) σε ένα ελεγχόμενο από τον εισβολέα DNS service. Ο εισβολέας μπορεί να ενεργοποιήσει το ελάττωμα με την αποστολή ενός κακόβουλου DNS Response. Αυτό θα προκαλέσει buffer overflow, οδηγώντας σε απομακρυσμένη εκτέλεση κώδικα.

Πως γίνεται αυτό; Σύμφωνα με τον Coulson, οι επηρεαζόμενες εκδόσεις του systemd επιτρέπουν σε έναν εισβολέα να εκχωρήσει ένα μικρού μεγέθους buffer για την επεξεργασία των πακέτων DNS, μέσω της εκχώρησης συγκεκριμένων μεγεθών στο dns_packet_new.

“Ένας κακόβουλος διακομιστής DNS μπορεί να εκμεταλλευτεί το γεγονός αυτό, αποκρινόμενος με ένα ειδικά κατασκευασμένο TCP payload, προκειμένου να ξεγελάσει το systemd-resolved στην εκχώρηση ενός buffer, που είναι πολύ μικρό, και στη συνέχεια να εγγράψει αυθαίρετα δεδομένα, στο τέλος του”, αναφέρει ο εμπειρογνώμονας.

Αυτή η ευπάθεια “out-of-bound” εγγραφής επιτρέπει σε έναν εισβολέα να κρασάρει το systemd ενός συστήματος ή να εγγράψει δεδομένα στη μνήμη, επιτρέποντας την εκτέλεση κώδικα στο μηχάνημα του στόχου. Το μόνο που χρειάζεται είναι ένα κακόβουλο πακέτο DNS.

Το ελάττωμα επηρεάζει το version 223 του Systemd και μεταγενέστερες εκδόσεις, συμπεριλαμβανομένου του version 233 που κυκλοφόρησε τον Μάρτιο.

Ποιες διανομές επηρεάζονται;

Η ευπάθεια επηρεάζει τα Ubuntu 17.04 και 16.10. Οι διανομές Debian Stretch (ή Debian 9), Buster (Debian 10) και Sid ( Debian Unstable), καθώς και άλλες διανομές Linux που χρησιμοποιούν Systemd, είναι επίσης  ευπαθείς.

Οι χρήστες Linux και οι διαχειριστές συστημάτων θα πρέπει να ενημερώσουν τις εγκαταστάσεις τους το συντομότερο δυνατό.

Πηγή

0 σχόλια :

Δημοσίευση σχολίου